蛙扑下载站:安全、绿色、放心的专业下载站! 首页|最近更新|专题集合|标签云|站内导航
七牛云图床一键下载工具v1.0.0绿色版下载

七牛云图床一键下载工具v1.0.0绿色版

  • 软件大小:527KB
  • 更新日期:2020-09-15 09:43:18
  • 软件语言:简体中文
  • 软件类别:上传下载
  • 软件授权:免费软件
  • 评分等级:
  • 插件情况:无插件请放心使用
  • 软件官网:http://www.vaopo.com/
  • 适用平台:Win All
本地下载文件大小:527KB
软件介绍 人气软件 相关文章 下载地址

七牛云图床一键下载工具是由蛙扑小编推荐的一款七牛云图床下载工具,主要用途为批量下载七牛云存储上的图片资源,并将其存储到本地上,方便用户对数据文件进行统计管理。可以单独针对某个日期上传的文件进行下载获取,以便快速找到需要的图片资源。

七牛云图床一键下载工具

七牛云图床下载工具功能

快速下载自己的七牛云储存空间中的图片,并保存到 桌面/学习笔记/markdown图片/日期中

七牛云图床下载工具使用

Cookie要自己抓,七牛云登录后,任何操作里面,都附带了cookie,打开F12,然后看network即可

日期这一栏,填写你想要下载的日期,然后就会下载那一天的日期,并且是按照阿拉伯数字排序进行下载

空间这一栏,填写你的七牛云储存空间即可

七牛云图床下载工具代码

.版本 2

.支持库 spec

.支持库 shell

.支持库 internet

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

皮肤_随机皮肤 (#皮肤_永不言败, #皮肤_七彩条幅, )

编辑框_日期.内容 = 到文本 (取日 (取现行时间 ()))

.子程序 _按钮1_被单击

.局部变量 返回值, 字节集

.局部变量 返回值文本, 文本型

.局部变量 链接, 文本型

.局部变量 json, 类_json

.局部变量 成员数量, 整数型

.局部变量 sum, 整数型

.局部变量 日期, 文本型

.局部变量 状态码, 逻辑型

.如果 (选择框1.选中)

    返回值 = 网页_访问 (“https://portal.qiniu.com/api/kodov2/rsf/list?bucket=mymarkdown-tuchuang&prefix=&baseUrl=http%3A%2F%2Ftc.glulu7.cn&delimiter=&allversion=false&limit=51&marker=”, 0, , #cookier, , #协议头, , , , , , , )

.否则

    返回值 = 网页_访问 (“https://portal.qiniu.com/api/kodov2/rsf/list?bucket=” + 编辑框_空间地址.内容 + “&prefix=&baseUrl=http%3A%2F%2Ftc.glulu7.cn&delimiter=&allversion=false&limit=51&marker=”, 0, , 编辑框_cookie.内容, , #协议头, , , , , , , )

.如果结束

返回值文本 = 到文本 (返回值)

调试输出 (返回值文本)

成员数量 = 寻找文本 (返回值文本, “preview_url”, , 真)

调试输出 (成员数量)

json.解析 (返回值文本)

sum = 0

日期 = 到文本 (取年份 (取现行时间 ())) + “年” + 到文本 (取月份 (取现行时间 ())) + “月” + 到文本 (取日 (取现行时间 ())) + “日”

.判断循环首 (sum < 成员数量)

    链接 = json.取通用属性 (“items[” + 到文本 (sum) + “]['preview_url']”, )

    .如果 (寻找文本 (链接, 到文本 (202009) + 编辑框_日期.内容, , 真) ≠ -1)

        调试输出 (链接)

        ' 写到文件 (取运行目录()+"\文本文档.txt", 编辑框1.内容)

        创建目录 (取特定目录 (3) + “\学习笔记\markdown图片\” + 日期)

        状态码 = 写到文件 (取特定目录 (3) + “\学习笔记\markdown图片\” + 日期 + “\” + 到文本 (sum) + “.png”, HTTP读文件 (链接))

        .如果 (状态码)

            编辑框_状态.加入文本 (“下载第” + 到文本 (sum) + “张图片成功” + #换行符)

        .否则

            编辑框_状态.加入文本 (“下载第” + 到文本 (sum) + “张图片失败” + #换行符)

        .如果结束

        ' HTTP读文件 (链接)

    .否则

    .如果结束

    sum = sum + 1

.判断循环尾 ()

下载周排行 下载总排行